
Web creation using Front Page 2003 - Basics 
 
Front Page has much in common with other Microsoft applications, so many of the editing 
processes will be familiar.     
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1. Starting a new web 
 
Open Front Page 

• Go to File -> New -> in the box which appears on the right of the screen select “One 
page web site” which is under the heading “New web site”, and again choose “One 
page web site”, the first option in the box which opens up 

• Before you click OK, look at the box which asks you to specify the location of the 
new web – it will already contain something like this: C:\My Documents\My Webs.   
You need to add the name of your web at the end like this: C:\My Documents\My 
Webs\schoolweb 

• Front Page will set up a new empty web, with an index page.   Your screen will now 
show the folder list on the left, a larger box in the centre with a tab saying “web site”, 
and a Microsoft dialogue box on the right.   Close the box on the right to give you 
more space. 

 
2. Setting up the structure 
 
You will see that at the moment the large box also contains the list of folders.   Click on the 

 button at the bottom of the page.    The page which appears will contain one box, 
marked “index.htm” 

• Right click on this and choose New Page – a new box will appear, linked below the index 
page. 
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• Right click on this and choose Re-name – type the name of the page e.g. about.   This is 
a file name and will form part of the web address for the page.  It is best to keep file 
names fairly short, and avoid capital letters, which can sometimes cause problems with 
publishing.    

• Create more pages in the same way till you have a page for each of the main sections of 
your web.   You can create pages below each of these main headings later in the same 
way. 

• NB your Home Page must always be called index.htm or index.html otherwise Front 
Page will be unable to publish your web 

• You can change the position of the pages (e.g. to arrange them alphabetically) by 
dragging them with the mouse. 

• To open a page from Navigation View, double click it 
 
If you have the Folder list open you will see that your new pages have now been added.    

To open or close the folder list click the  button.   If you click the down arrow next to this 
button you will see the option to show the navigation pane – this shows all your pages as you 
have set them up in the navigation structure.   Buttons at the bottom of the window also give you 
the option of toggling between these two views. 
 
3. Setting up a template 
 
There will be some information that you want to appear on every page, e.g. links to your main 
pages.   You may also want to standardise things like, font, font colour and background colour.   
You can do this by setting up a Dynamic Web Template (DWT).   There is a separate information 
sheet on this, as you will need to familiarise yourself with other aspects of Front Page before 
creating a DWT. 
 
4.1. Tables 
 
It is advisable to put all of the information you want on each page into tables.   This helps to keep 
the information where you want it on the page. 
 
To create a table either: 

• Click on the Insert Table icon  on the standard toolbar, and 
• Highlight the number of rows and columns you think you will need 

or 
• Go to Table and choose Insert Table, and 
• Type in the number of rows and columns you want 

 
To change the way the table looks either right click somewhere within the table and choose Table 
Properties, or go to Table -> Properties -> Table in the drop down menu.   Properties you might 
want to set are: 

• Table width – setting this to 100% will ensure the table justifies to different screen 
sizes – generally people are happy to scroll up and down, but find it irritating to have 
to scroll right and left. 

• Border size – if you do not want the borders to show in the published web, set their 
size to 0.   The borders will show as a dotted line in Front Page. 

• Cell padding – set to about 5 - this leaves a bit of space around the edges of the cell, 
so that if you have a picture in one cell and text in the next the text is not hard up 
against the picture. 

 
NB: Cells will expand vertically to accommodate whatever text or pictures you include within 
them, so it is not usually necessary to set the cell or table height. 
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You can add more rows later; you can also merge cells to get, for example, a cell that stretches 
the full width of the page for your header.   You can also put a table within a table.   Putting one 
table immediately below another looks seamless when published, and can get round problems 
which sometimes arise from merging and splitting cells, or placing tables inside tables. 
 
FP 2003 has a range of pre-set options for table layout, which you may want to investigate at 
some point, e.g. to make your index page more imaginative, but they can be tricky to get the hang 
of, and fairly time consuming.  
 
4.2 Cells – positioning text etc 
 
You can align your text to left, centre or right as you would in Word.   FP automatically centres 
text or objects vertically, so if you have two or more cells across the page you may need to 
change the default so that your text or pictures are all at the top of their cells.   To do this either: 

• click into the cell  
• right click and chose cell properties 
• go to Vertical Alignment and choose “top” 

or 
• go to Table -> Table properties -> cell 
• go to Vertical Alignment and choose “top” 

 
5. Adding text 
 
You can type and format your text much as you would in a Word document.   It is best not to use 
underlining for emphasis – this will cause confusion, as hyperlinks (see below) generally display 
as underlined text. 
 
You can also copy and paste text from a document, or import a whole file.   To import a file: 

• With the cursor in the appropriate cell of the table, go to Insert and choose File 
• In the window which opens, make sure the “Files of type” box is set to “All files” 
• Find the file you want and click “open” 
• FP may ask if you want to install a converter – if you say “no” it will still import the file 

 
Front Page converts the file to html (the format used for web pages) as it imports it.   This often 
means that some re-formatting is necessary to make the document display as you want it to.   
Some features of Word, such as text boxes cannot be edited after importing, and you may find 
that you need to remove them and display the information in a different way.   More recent 
versions of Word enable you to save a document as a web page.   However, some re-formatting 
still appears to be necessary. 
 
It is sometimes easier to get rid of Word formatting altogether by copying the text into Notepad, 
then copying and pasting from there. 
 
6. File size 
 
Be aware of file size – at the bottom right of the Front Page screen is a box which gives you the 
estimated time it will take to download the page, i.e. the amount of time someone looking at the 
web site will have to wait for the page to open.   It will say something like: 0.06@56kbps.   This 
means 6 seconds using a 56 baud modem    If you right click you can change to a different 
modem speed, but 56kbps is fairly usual these days.  Your index page in particular needs to load 
quickly or people will not bother to look at your site at all. 
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7. Checking what you have done 
 
To see what your web site will look like when published you need to look at it in a web browser.   
To do this: 

• Save your work 
• Go to File -> Preview in browser or 

• Click the  button in the toolbar 
 
8.1. Hyperlinks 
 
Hyperlinks take you from one page to another within your web site and to other, external web 
sites.   You can make any piece of text or any graphic into a hyperlink.   You will need links to 
each main section of your site on every page, plus links within each section.    
 
To make a hyperlink: 

• Select the piece of text or the graphic you wish to make into a link 

• Go to Insert and choose Hyperlink, or click the hyperlink icon on the toolbar:  
• Click on the name of the page you wish to link to, and click OK.   (NB make sure you 

link to the page and not the temp. file which shows at the top of the list when a page 
is open) 

• If you are linking to an external web site, type the web address into the url line, or you 
can copy and paste. 

 
8.2. Setting up a hyperlink to open in a new window 
 
If you want people to be able to get back to your site easily after visiting an external link you can 
set up the hyperlink so that the external site opens in a new window.   Your own site will remain 
in the background, and people will be able to return to it by simply closing the other window.   To 
set this up: 

• Make your hyperlink in the usual way 
• With the Insert Hyperlink window still open, click the Target frame button  
• Choose New window and click OK 

 
9. Shared borders 
 
You can set up a shared border to appear on every page of your web.   This could include: links 
to the main sections of your site, a contact e-mail (use the generic school e-mail, not a personal 
one), a note to say when the site was last updated, and a copyright mark.   Amending the shared 
border on one page will ensure that the change appears on all pages. 
 
NB Shared borders depend on Front Page Extensions, and these will no longer be supported 
after 2011, so although you will be able to use shared borders for a few years yet it would be 
better to set up a Dynamic Web Template (see separate sheet), which will contain all of the 
information you would put in shared borders, and will also allow you to standardise the formatting 
of your pages. 
 
To set up a shared border: 

• Go to Format and select Shared borders 
• Choose “all pages” 
• Choose where you want the border to appear – the top or bottom of the page is 

generally better than the sides, and if your pages are likely to contain a lot of text you 
may wish to have the shared border at both top and bottom – just select both 

• Click OK 
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Replace the text which appears with your own text, in a table if you wish.   If, for example, you are 
using the shared border for hyperlinks to provide navigation between the main sections of your 
site: 

• Type the names of the sections with a space, vertical line (bottom left of keyboard 
above \), space, between them e.g. news | pupils | staff 

• Make each term into a hyperlink.   Try to just select the name, not the space before 
or after it – if hyperlinks overlap it causes problems 

• Remember to include the Home Page so that people can get back to the front of your 
site 

 
10. Changing colours, fonts etc 
 
10.1. Fonts 
 
One of the more irritating features of Front Page is that there is no simple way to change the 
default font (see Themes 9.4 below).   This means that if you choose to use anything other than 
the default font you will need to change it on every page as you go along.   It is best to use a fairly 
common font e.g. Arial, Comic Sans, Times New Roman, which most people will have.   If you 
choose something unusual others may have problems viewing your site. 
 
10.2. Colours 
 
You can change text colour as you would in Word by highlighting a section of text and going to 
Format -> Font and choosing another colour from the drop down menu.  
 
Whatever colours you use, make sure there is a good contrast between text and background, and 
that the text is clear and easy to read.   If you can, look at your site on different monitors – colours 
tend to look different on a laptop. 
 
10.3. Format background 
 
You can set the font and background colour for the whole page by going to Format -> 
background.   Click the Formatting tab: you can now choose a text colour, a background colour 
and also change the colour of your hyperlinks 
 
Some of the options available can cause problems: 

• You can choose different colours for Hyperlink, Visited Hyperlink, Active Hyperlink.   
These do not always display properly; there is a tendency to stick at the Visited 
Hyperlink colour.   In practice it has proved best to use the same colour for all three. 

• Hyperlink rollover effects (this is on the Advanced tab) – these make a hyperlink 
change colour when you run your mouse over it – sometimes the text changes size 
as well!   If you decide to use this it needs to be set on each page. 

• Background picture – picture will tile to fill the screen, so you may not get the effect 
you want; can make text very hard to read. 

 
11. Graphics 
 
Graphics may be digital photographs, scanned images, clip art etc.  Appropriate graphics will 
immediately make your site more interesting.   You must, however, be careful of file size.   Ideally 
graphics used on a web site should not be more than about 15K – check the load time in the 
bottom right hand corner.   See below for information on how to reduce file size. 
 
NB Photographs of pupils should not be used.   Pupils’ work should only be included with 
parental permission.    
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You can put graphics within individual cells to position them on your page, or you can place them 
so that your text wraps around them. 
 
To place a graphic within a cell in a table: 

• Click into the cell 
• Go to Insert -> Picture – then choose either Clip art or From file 
• If you choose From file you may need to navigate to wherever the graphic is on your 

computer, then click OK 
 
To place a graphic within your text: 

• Click at the beginning of the paragraph 
• Go to Insert -> Picture, find the picture you want and click OK 
• Click on the graphic to select it 
• Go to Format -> Position, choose a wrapping style and click OK 

 
11.1. Reducing the file size of graphics 
 
To reduce the file size of a graphic: 

• Insert the graphic in your page, click it to highlight it and drag the corner to re-size it 
• A box will appear next to the bottom right corner 
• Click the down arrow to get this: 

   
• Click next to Resample Picture to Match Size 
• Your picture will be tidied up and the file size reduced – check the load time at the bottom 

of your screen 
• This facility just re-sizes - if you need to crop your picture, or if you want to reduce the file 

size without making the picture smaller you will have to use a graphics package (e.g. 
Adobe Photoshop). 

 
11.2. Saving graphics 
 
When you save a page which includes a graphic, a box headed “embedded files to save” will 
open.   This gives you the opportunity to decide where the graphic is to be saved.   You should 
aim to save all graphics to your Images file.   If “Images” does not appear under “Folder” in the 
box, go to “Change folder” and choose “Images”. 
 
11.3. Making thumbnails 
 
If you want to display a number of pictures on a page, you can keep the load time down by 
turning them into thumbnails.   To create a thumbnail: 

• Click on a graphic to select it – a graphics toolbar will appear at the bottom of the 
page 

• Click the “Auto Thumbnail” button:  
• This will create a small version of your graphic, which acts as a hyperlink to the larger 

version. 
• Both versions need to be saved in your images file. 

 
To change the size and appearance of thumbnails: 

• Go to Tools -> Page Options 
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• Click the Auto Thumbnail tab in the box which opens, make your changes and click 
OK.    

• NB you need to do this before creating the thumbnails. 
 
11.4. Adding alt. text 
 
You can add text so that when someone moves their mouse so that the cursor rests on the 
picture they will get information about the picture.   To do this: 

• Right click the picture and choose “Picture properties” 
• The box which appears has three tabs: General, Video and Appearance – you want 

General 
• About half way down you will see “Text” – type your information into the box and click 

OK 
 
11.5. Photo gallery 
 
This is a feature of Front Page, which enables you to very quickly create a professional looking 
display of a group of images. 

• Go to Insert -> Picture -> New Photo Gallery 
• On the “Pictures” tab click “Add”, choose your source (file, camera etc), select the 

group of pictures you want to include and click “open” 
• FP will import them, and you have the opportunity to remove or edit them 
• On the Layout tab select a layout 
• FP will generate thumbnails and create your photo gallery 
• To make changes right click on the gallery and choose “Photo gallery properties” 

 
NB it is still best to edit the file size of your pictures in a graphics package first. 
 
12. Adding a marquee 
 
A marquee contains text which scrolls across the page, and can be used e.g. to draw attention to 
a special event or achievement, or simply to add a bit of movement to your index page.   It can be 
very effective, but if overused will tend to irritate. 
 
To set up a marquee: 

• Place the cursor where you want the marquee to run 
• Go to Insert -> Web component -> Dynamic effects 
• Select Marquee and click Finish 
• In the Marquee Properties box which appears you can type your text, decide on 

background colour etc 
• To format your text click Style -> Format -> Font 

 
13. Copyright 
 
Before you publish make sure that you have copyright clearance for all of the material included on 
your site.   Any material not created by you is someone else’s copyright, so if for example you 
want to include a worksheet, which you have created, but which is illustrated with pictures from a 
book, you will need permission to use the illustrations.  If in doubt check with the Copyright 
Officer, Iain Mackay, at Culloden Academy (Tel 01463 790851).  Remember, your published web 
site will be able to be viewed by anyone, anywhere in the world. 
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14. Meta tags – to help search engines find your site 
 
Front Page converts your web pages into html.   When it converts it includes the name of each 
page as you have named it when you set it up under Navigation (see page 2).   This is a meta 
tag, and it is what search engines pick up.    
 
Your home page has to be called “index.htm” or FP will not be able to publish your site properly.   
This is not helpful to people searching for information on your school, so you need to give the 
page a title: 

• From the index page go to Format -> Background 
• Click on the General tab and type in a title e.g. school name, Highland 
• You can do the same for other pages if you feel the name you have given the page 

does not adequately reflect the content – e.g. you may have called a page “board”, 
but may wish the title to be “school board minutes” 

 
15. Publishing 
 
Publishing from Front Page via http is very straightforward.   If you are publishing from a 
computer attached to the curriculum network (you need to be logged on as Administrator) the first 
thing you have to do is change one of your web browser’s settings*: 

• Open Internet Explorer 
• Go to Tools -> Internet options 
• Click on the Connections tab 
• Then click the LAN settings button 
• Uncheck the box next to “Use a proxy server for your LAN” 
• When you have finished publishing go back into Internet Explorer and check this box 

again to ensure that pupils have filtered internet access – if you forget to do this it will 
look as if the internet link is unavailable. 

 
To publish: 

• Make sure each page has been saved 
• Go to File -> Publish site 
• Under Remote web server type select “Front Page or share Point services” 
• In the box which asks you to specify the location for publishing, type the url of your 

site (e.g. http://www.schoolname.highland.sch.uk) and click Publish 
• Type in your username and password when asked 
• Wait for the files to load, then click “Publish” 
• Unless you have a lot of graphics on your site, it should not take more than a few 

minutes to publish 
• When the site is published a box will appear asking if you want to view your 

published site 
 
*If you find you are unable to change the proxy settings because the Connections tab is not 
available, contact the ICT Unit for instructions 
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